Hi everyone,
I can't figure out how to do this.
We're expanding our network one of our sites, and have bought an additional 3 EX2200 switches to the existing 2 that's setup in a Virtual Chassis.
The plan is to have one of the switches on a new rack that will contain all the servers, and the other four act as access switches to the workstations. Now I just realized that the virtual chassis for ex2200 max out at 4 units, and I can't add the other switch on the server rack.
So instead, I'm planning to do LACP (802.3ad) on the rack switch, to the virtual chassis. But I want the link between the two to be a VLAN trunk, so I can still use the switch on the server rack on the same VLAN as the one in the VC. Please take note of the LACP interfaces are across different member switches (all port 46).
The thing is, I can't seem to set this up properly. Access switch ports 0/0/46 and 1/0/46 are LACPd to connect to the server switch 0/0/46 and 0/0/47 respectively. I connected access switch ports 0/0/1 (Server VLAN), and another on server swtich ports 0/0/1 (Server VLAN). I got the LACPs up and running, but switching for the workstations on the SERVER vlan won't talk to each other.
Config (redacted some parts) is as follows:
# JEX-SWITCH (Access switch Virtual Chassis)
chassis {
aggregated-devices {
ethernet {
device-count 5;
}
}
}
interfaces {
ge-0/0/0 {
unit 0 {
family ethernet-switching {
vlan {
members PHASE-1;
}
}
}
}
ge-0/0/1 {
unit 0 {
family ethernet-switching {
vlan {
members SERVERS;
}
}
}
}
ge-0/0/46 {
ether-options {
802.3ad ae0;
}
}
ge-1/0/46 {
ether-options {
802.3ad ae0;
}
}
ae0 {
aggregated-ether-options {
lacp {
active;
}
}
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members [ PHASE-1 SERVERS default ];
}
}
}
}
vlans {
unit 0 {
family inet {
address 10.0.0.2/24;
}
}
unit 21 {
family inet {
address 10.0.21.1/24;
}
}
unit 101 {
family inet {
address 10.0.101.1/24;
}
}
}
}
virtual-chassis {
preprovisioned;
member 0 ...
member 1 ...
member 3 ...
member 4 ...
}
vlans {
PHASE-1 {
vlan-id 21;
l3-interface vlan.21;
}
SERVERS {
vlan-id 101;
l3-interface vlan.101;
}
default {
vlan-id 0;
}
}
---------------------------------------------------------
# SERVER-SWITCH
chassis {
aggregated-devices {
ethernet {
device-count 5;
}
}
}
interfaces {
ge-0/0/0 {
unit 0 {
family ethernet-switching {
vlan {
members PHASE-1;
}
}
}
}
ge-0/0/1 {
unit 0 {
family ethernet-switching {
vlan {
members SERVERS;
}
}
}
}
ge-0/0/46 {
ether-options {
802.3ad ae0;
}
}
ge-0/0/47 {
ether-options {
802.3ad ae0;
}
}
ae0 {
aggregated-ether-options {
lacp {
active;
}
}
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members [ PHASE-1 SERVERS default ];
}
}
}
}
vlans {
unit 0 {
family inet {
address 10.0.0.3/24;
}
}
unit 101 {
family inet {
address 10.0.101.2/24;
}
}
}
}
vlans {
PHASE-1 {
vlan-id 21;
l3-interface vlan.21;
}
SERVERS {
vlan-id 101;
l3-interface vlan.101;
}
default {
vlan-id 0;
}
}