I know there is someone out there that can help me....
Re: Uplink from EX3300 VC to EX2300-C not passing traffic for Default Vlan (1)
Re: Uplink from EX3300 VC to EX2300-C not passing traffic for Default Vlan (1)
Well, I was finally able to resolve my issue with the configuration on the EX2300-C switch. For the trunk interfaces / ports including the link aggregation (ae0) on the EX2300 switch, I had to add the default Vlan (1) as a member to all trunk ports and as the native vlan.
Now I would like to understand why it is working. Maybe someone can explain to me.
The changes to the configuration is highlighted in bold.
## Last changed: 2017-08-25 19:51:30 EDT
version 15.1X53-D56;
system {
auto-snapshot;
time-zone US/Eastern;
root-authentication {
encrypted-password "$5$0ljxQZMc$AOvp4IMWtCxg2.bTFp.n0YKwwAp.scb3i625MeKbK.6";
}
services {
ssh {
protocol-version v2;
}
telnet;
netconf {
ssh;
}
web-management {
http;
}
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
processes {
dhcp-service {
traceoptions {
file dhcp_logfile size 10m;
level all;
flag all;
}
}
}
}
chassis {
aggregated-devices {
ethernet {
device-count 1;
}
}
}
interfaces {
ge-0/0/0 {
native-vlan-id 1;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members [ 30 default ];
}
storm-control default;
}
}
}
ge-0/0/1 {
native-vlan-id 1;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members [ 30 default ];
}
storm-control default;
}
}
}
ge-0/0/2 {
native-vlan-id 1;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members [ 30 default ];
}
storm-control default;
}
}
}
ge-0/0/3 {
native-vlan-id 1;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members [ 30 default ];
}
storm-control default;
}
}
}
ge-0/0/4 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/5 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/6 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/7 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/8 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/9 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/10 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/11 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/1/0 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
xe-0/1/0 {
ether-options {
802.3ad ae0;
}
}
ge-0/1/1 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
xe-0/1/1 {
ether-options {
802.3ad ae0;
}
}
ae0 {
description "A LAG Uplink to EX3300 Virtual Chassis Switch";
native-vlan-id 1;
aggregated-ether-options {
minimum-links 1;
lacp {
active;
periodic fast;
}
}
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members [ 30 default ];
}
}
}
}
irb {
unit 0 {
family inet {
dhcp {
vendor-id Juniper-ex2300-c-12p;
}
}
}
}
me0 {
unit 0 {
family inet {
address 192.168.99.30/24;
}
}
}
}
forwarding-options {
storm-control-profiles default {
all;
}
}
routing-options {
static {
route 0.0.0.0/0 next-hop 192.168.99.1;
}
}
protocols {
lldp {
interface all;
}
lldp-med {
interface all;
}
igmp-snooping {
vlan default;
}
rstp {
interface ge-0/0/0;
interface ge-0/0/1;
interface ge-0/0/2;
interface ge-0/0/3;
interface ge-0/0/4;
interface ge-0/0/5;
interface ge-0/0/6;
interface ge-0/0/7;
interface ge-0/0/8;
interface ge-0/0/9;
interface ge-0/0/10;
interface ge-0/0/11;
interface ae0;
}
}
vlans {
Guest_Network {
description "Guest Network";
vlan-id 30;
}
}
poe {
interface all;
}
Re: Uplink from EX3300 VC to EX2300-C not passing traffic for Default Vlan (1)
Glad you have it working now. I'm sure the process was frustrating.
You have two options to add vlans to trunk ports, your method is above is one under members of the interface.
The second option is to have the trunk port configured as simply trunk mode and then add the interface into all the vlans under that heirarchy. For this method you would need to create the default vlan definition under vlans.
Best practice is to create that vlan, the devices ship with a minimum configuration so that all ports are communicating.
You are now sending the vlan-id 1 tagged on the trunk port. When listed in members these are tagged. I believe if you had created the vlan definition for default the original configuration would have worked.
default { vlan-id 1; } }
https://kb.juniper.net/InfoCenter/index?page=content&id=KB17419
Re: Uplink from EX3300 VC to EX2300-C not passing traffic for Default Vlan (1)
spuluka wrote:Glad you have it working now. I'm sure the process was frustrating.
You have two options to add vlans to trunk ports, your method is above is one under members of the interface.
The second option is to have the trunk port configured as simply trunk mode and then add the interface into all the vlans under that heirarchy. For this method you would need to create the default vlan definition under vlans.
Best practice is to create that vlan, the devices ship with a minimum configuration so that all ports are communicating.
You are now sending the vlan-id 1 tagged on the trunk port. When listed in members these are tagged. I believe if you had created the vlan definition for default the original configuration would have worked.
default { vlan-id 1; } }https://kb.juniper.net/InfoCenter/index?page=content&id=KB17419
I tried your recomendation and it did not work. Here is the updated configuration based on your recommendation. The statements in bold is what was changed:
## Last changed: 2017-08-26 08:48:25 EDT
version 15.1X53-D56;
system {
auto-snapshot;
time-zone US/Eastern;
root-authentication {
encrypted-password "$5$0ljxQZMc$AOvp4IMWtCxg2.bTFp.n0YKwwAp.scb3i625MeKbK.6";
}
services {
ssh {
protocol-version v2;
}
telnet;
netconf {
ssh;
}
web-management {
http;
}
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
processes {
dhcp-service {
traceoptions {
file dhcp_logfile size 10m;
level all;
flag all;
}
}
}
}
chassis {
aggregated-devices {
ethernet {
device-count 1;
}
}
}
interfaces {
ge-0/0/0 {
native-vlan-id 1;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members 30;
}
storm-control default;
}
}
}
ge-0/0/1 {
native-vlan-id 1;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members 30;
}
storm-control default;
}
}
}
ge-0/0/2 {
native-vlan-id 1;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members 30;
}
storm-control default;
}
}
}
ge-0/0/3 {
native-vlan-id 1;
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members 30;
}
storm-control default;
}
}
}
ge-0/0/4 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/5 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/6 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/7 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/8 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/9 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/10 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/0/11 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
ge-0/1/0 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
xe-0/1/0 {
ether-options {
802.3ad ae0;
}
}
ge-0/1/1 {
unit 0 {
family ethernet-switching {
storm-control default;
}
}
}
xe-0/1/1 {
ether-options {
802.3ad ae0;
}
}
ae0 {
description "A LAG Uplink to EX3300 Virtual Chassis Switch";
native-vlan-id 1;
aggregated-ether-options {
minimum-links 1;
lacp {
active;
periodic fast;
}
}
unit 0 {
family ethernet-switching {
interface-mode trunk;
vlan {
members 30;
}
}
}
}
irb {
unit 0 {
family inet {
dhcp {
vendor-id Juniper-ex2300-c-12p;
}
}
}
}
me0 {
unit 0 {
family inet {
address 192.168.99.30/24;
}
}
}
}
forwarding-options {
storm-control-profiles default {
all;
}
}
routing-options {
static {
route 0.0.0.0/0 next-hop 192.168.99.1;
}
}
protocols {
lldp {
interface all;
}
lldp-med {
interface all;
}
igmp-snooping {
vlan default;
}
rstp {
interface ge-0/0/0;
interface ge-0/0/1;
interface ge-0/0/2;
interface ge-0/0/3;
interface ge-0/0/4;
interface ge-0/0/5;
interface ge-0/0/6;
interface ge-0/0/7;
interface ge-0/0/8;
interface ge-0/0/9;
interface ge-0/0/10;
interface ge-0/0/11;
interface ae0;
}
}
vlans {
Guest_Network {
description "Guest Network";
vlan-id 30;
}
default {
vlan-id 1;
}
}
poe {
interface all;
}
EX2300-C 12P - Temperature is extremely hot on this unit. What is a safe temperature?
I have the EX2300-C 12P unit runing JUNOS image 15.1X53-D56. The two 10G ports are being used as an uplink to my EX3300 switch. The management port is being used as well as the first 3 ports on the switch.
The temperature is ranging from 52 to 56 degrees celsius. That is over 125 degrees fahrenheit. What is the normal / safe temperature for this unit? Please advise.
Re: EX2300-C 12P - Temperature is extremely hot on this unit. What is a safe temperature?
Appears to be between 42-62.
root@ex2300c > show chassis temperature-thresholds Fan speed Yellow alarm Red alarm Fire Shutdown (degrees C) (degrees C) (degrees C) (degrees C) Item Normal High Normal Bad fan Normal Bad fan Normal FPC 0 CPU Sensor 42 62 65 65 75 75 80 FPC 0 PSU Sensor 40 61 65 65 75 75 80 {master:0} root@ex2300c>
Re: Remove interface from range
I cannot get the CLI to accept those commands. I'm not sure what I'm doing wrong.
Re: Remove interface from range
This the message when I attempt to delete the interface range:
{master:0}[edit]
obtech@SAND-IDF-Faculty# ...ange ge-4/0/36 to ge-4/0/47
warning: statement not found
Command I'm typing is
delete interfaces interface-range wireless-ap-ports member-range ge-4/0/36 to ge-4/0/47
Re: Remove interface from range
This is the error when I try and commit the following commands:
set interface-range wireless-ap-ports member-range ge-4/0/37 to ge-4/0/47
set interfaces ge-4/0/36.0 family ethernet-switching port-mode access vlan members SecurityCameras
Error
obtech@SAND-IDF-Faculty# commit
[edit interfaces ge-4/0/37 unit 0 family]
'ethernet-switching'
Access interface ge-4/0/37.0 cannot have native-vlan-id
error: configuration check-out failed
I believe the configuration is being inherited from this:
interface-range wireless-ap-ports {
member-range ge-4/0/36 to ge-4/0/47;
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members [ Wireless CSMSBYOD ];
}
native-vlan-id 5;
}
}
}
Re: How To Find MAC Address of device attached to switchport
How about the device IP address?
I know the device mac, connected to juniper port 0/0/1. How do i know the IP address of the device? (which is static)
Re: How To Find MAC Address of device attached to switchport
Akazi2017 wrote:How about the device IP address?
I know the device mac, connected to juniper port 0/0/1. How do i know the IP address of the device? (which is static)
You could probably use a protocol that maps and IP to a mac address.
Re: Remove interface from range
>show configuration interfaces so we can see all the configuration on the interfaces. The advice given means you have to delete the interface range and create a new one, then configure the ge-0/0/36 as an access port. In fact after deleting the interface range, delete interface ge-0/0/36, recreate the new interface range as indicated minus ge-0/0/36 and then configure ge-0/0/36 as an access port.
#delete interfaces interface-range wireless-ap-ports
#set interfaces interface-range wireless-ap-ports member-range ge-4/0/37 to ge-4/0/47
#set interfaces interface-range wireless-ap-ports port-mode trunk unit 0 family ethernet-switching port-mode trunk vlan members CSMSBYOD
#set interfaces interface-range wireless-ap-ports port-mode trunk unit 0 family ethernet-switching port-mode trunk vlan members Wireless
Re: EX-2300 15.1X53-D56 DHCP snooping untrust on trunk
Options
trusted | — | The interface specified in this group is trusted. DHCP snooping and DHCPv6 snooping do not apply to the trusted interface. Likewise, DAI, IP source guard, IPv6 source guard, and IPv6 neighbor discovery inspection—even if they are enabled for the VLAN—do not apply to the interface that is configured with the overrides and the trusted options. Access interfaces are untrusted by default. |
untrusted | — | (Only for EX9200) The interface specified in this group is untrusted. Trunk interface are trusted by default. Access interfaces are untrusted by default. |
Looks like you may have to create an ACL blocking DHCP server traffic while allowing all other traffic, and install it on the trunk ports.
Re: Strange log messages in EX2300
Here's my syslog configuration for this device:
syslog { user * { any emergency; } host xx.xx.xx.xx { any any; source-address xx.xx.xx.xx; } file messages { any notice; authorization info; } file interactive-commands { interactive-commands any; } }
And this is what I'm getting on syslog server - https://pastebin.com/tZj2GYBN
Re: Remove interface from range
I get as far as the "set interfaces interface-range wireless-ap-ports port-mode trunk unit 0 family ethernet-switching port-mode trunk vlan members CSMSBYOD" but it will accept the port-mode parameter. Listed below is result of show configuration interfaces:
=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2017.08.28 07:24:03 =~=~=~=~=~=~=~=~=~=~=~=
login as: obtech
obtech@10.5.0.23's password:
--- JUNOS 12.3R11.2 built 2015-09-24 11:15:41 UTC
{master:0}
obtech@SAND-IDF-Faculty> show configuration interfaces
interface-range uplink_ports {
member-range xe-0/1/0 to xe-0/1/3;
member-range ge-0/1/0 to ge-0/1/3;
member-range xe-1/1/0 to xe-1/1/3;
member-range ge-1/1/0 to ge-1/1/3;
member-range xe-2/1/0 to xe-2/1/3;
member-range ge-2/1/0 to ge-2/1/3;
member-range xe-3/1/0 to xe-3/1/3;
member-range ge-3/1/0 to ge-3/1/3;
member-range xe-4/1/0 to xe-4/1/3;
member-range ge-4/1/0 to ge-4/1/3;
member-range xe-5/1/0 to xe-5/1/3;
member-range ge-5/1/0 to ge-5/1/3;
member-range xe-6/1/0 to xe-6/1/3;
member-range ge-6/1/0 to ge-6/1/3;
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members [ MGMT CSMS-Servers SAND-Voice CSMS-MDF CSMS-RM100 CSMS-RM102 CSMS-FacultyDining CSMS-RM236 CO-OP-Office CSMS-ShopWing Wireless VLAN189 CSMS-Field SecurityCameras CSMSBYOD ];
}
---(more)--- native-vlan-id 1;
}
}
}
interface-range data-ports {
member ge-0/0/0;
unit 0 {
family ethernet-switching {
vlan {
members VLAN189;
}
}
}
}
interface-range wireless-ap-ports {
member-range ge-4/0/36 to ge-4/0/47;
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members [ Wireless CSMSBYOD ];
}
native-vlan-id 5;
---(more)--- }
}
}
interface-range camera-ports {
member-range ge-4/0/1 to ge-4/0/35;
unit 0 {
family ethernet-switching {
vlan {
members SecurityCameras;
}
}
}
}
inactive: interface-range phone-system-ports {
member ge-0/0/3;
unit 0 {
family ethernet-switching {
vlan {
members SAND-Voice;
}
}
}
}
---(more 29%)--- inactive: interface-range Room100 {
member ge-0/0/4;
unit 0 {
family ethernet-switching {
vlan {
members CSMS-RM100;
}
}
}
}
inactive: interface-range Room102 {
member ge-0/0/5;
unit 0 {
family ethernet-switching {
vlan {
members CSMS-RM102;
}
}
}
}
interface-range FacultyDining {
member ge-4/0/0;
member-range ge-0/0/0 to ge-0/0/47;
---(more 40%)--- member-range ge-1/0/0 to ge-1/0/47;
member-range ge-2/0/0 to ge-2/0/47;
member-range ge-3/0/0 to ge-3/0/47;
unit 0 {
family ethernet-switching {
vlan {
members CSMS-FacultyDining;
}
}
}
}
inactive: interface-range Room236 {
member ge-0/0/7;
unit 0 {
family ethernet-switching {
vlan {
members CSMS-RM236;
}
}
}
}
inactive: interface-range CO-OP-Office {
member ge-0/0/8;
---(more 50%)--- unit 0 {
family ethernet-switching {
vlan {
members CO-OP-Office;
}
}
}
}
inactive: interface-range MDF {
member ge-0/0/9;
unit 0 {
family ethernet-switching {
vlan {
members CSMS-MDF;
}
}
}
}
inactive: interface-range ShopWing {
member ge-0/0/10;
unit 0 {
family ethernet-switching {
vlan {
---(more 60%)--- members CSMS-ShopWing;
}
}
}
}
inactive: interface-range Field {
member ge-0/0/11;
unit 0 {
family ethernet-switching {
vlan {
members CSMS-Field;
}
}
}
}
inactive: interface-range DoorControl {
member ge-4/0/0;
unit 0 {
family ethernet-switching {
vlan {
members CSMS-Field;
}
}
---(more 70%)--- }
}
ge-2/0/6 {
description "Sodexo ADP Time Clock";
}
ge-3/0/23 {
description "HVAC Booster patch panel port 36";
}
ge-3/0/25 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members SecurityCameras;
}
}
}
}
ge-3/0/27 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
---(more 80%)--- members SecurityCameras;
}
}
}
}
ge-3/0/29 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members SecurityCameras;
}
}
}
}
ge-3/0/31 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members SecurityCameras;
}
}
---(more 91%)--- }
}
ge-4/0/0 {
description "Door Access Panel";
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members SecurityCameras;
}
}
}
}
vlan {
unit 5 {
family inet {
address 10.5.0.23/16;
}
}
}
{master:0}
obtech@SAND-IDF-Faculty>
Re: Remove interface from range
Sorry...I meant to say it WILL NOT accept the port-mode trunk parameter
Re: Remove interface from range
These were the commands that worked:
set interfaces interface-range wireless-ap-ports unit 0 family ethernet-switching port-mode trunk vlan members CSMSBYOD
set interfaces interface-range wireless-ap-ports unit 0 family ethernet-switching port-mode trunk vlan members Wireless
Thanks for all your help with this
Re: Strange log messages in EX2300
There does not seem to be enough information here for me to tie this to a particular port. But there are errors for both logical (ifl) and physical (ifd) in the logs. I'm not sure how to interpret the "port 28" on the ifd error but assume this might be the index of that physical interface. Try this search to see if there is a match:
show interfaces extensive | find "Interface index: 28"
This will start the interface output in the affected physical interface. Look at the name of the next interface that shows.
Run show interfaces terse and see the name of the interface before that interface and this will be the one with the matching index 28. Thus the potential source of the messages.
EX2300-C can't load 'kernel'
*****
can't load 'kernel'
Type '?' for a list of commands, 'help' for more detailed help.
loader>
*****
My EX's are in this state and none of the online recovery methods are working. I can get to u-boot and loader prompts. The USB and TFTP options of install command fail.
Can someone please chime in on any recovery tips? Thank you in advance.
Re: EX2300-C can't load 'kernel'
Can you send the failure output? Honestly it sounds like bad hardware.