I am having trouble getting IP connectivity between two Cisco ASR routers connected to a pair of Juniper EX4500-40f switches in a virtual-chassis setup. The Juniper switch is the new element here, as a similar setup has worked connected to different vendor's switches.
I have included all of the configuration details here, I've been racking my brain over this all weekend and can't figure out what is wrong. No pings between any of the addresses work.
ASR1 Gig0/0/5 (10.10.100.1) is connected to Juniper6 ge-0/0/30
ASR2 Gig0/0/5 (10.10.100.2) is connected to Juniper6 ge-1/0/34
Transceiver types are the same on both sides for both links (1Gb SX). Media is correct.
ASR1
interface GigabitEthernet0/0/5
mtu 9216
no ip address
negotiation auto
!
interface GigabitEthernet0/0/5.100
encapsulation dot1Q 100
ip address 10.10.100.1 255.255.255.0
mtu 9216
no ip address
negotiation auto
!
interface GigabitEthernet0/0/5.100
encapsulation dot1Q 100
ip address 10.10.100.1 255.255.255.0
GigabitEthernet0/0/5 unassigned YES NVRAM up up
Gi0/0/5.100 10.10.100.1 YES manual up up
Gi0/0/5.100 10.10.100.1 YES manual up up
ASR2
interface GigabitEthernet0/0/5
no ip address
negotiation auto
!
interface GigabitEthernet0/0/5.100
encapsulation dot1Q 100
ip address 10.10.100.2 255.255.255.0
no ip address
negotiation auto
!
interface GigabitEthernet0/0/5.100
encapsulation dot1Q 100
ip address 10.10.100.2 255.255.255.0
GigabitEthernet0/0/5 unassigned YES NVRAM up up
Gi0/0/5.100 10.10.100.2 YES manual up up
Gi0/0/5.100 10.10.100.2 YES manual up up
Juniper6
ge-0/0/30 {
description "ASR1 0/0/5";
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members VLAN100;
}
native-vlan-id VLAN999;
}
}
}
description "ASR1 0/0/5";
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members VLAN100;
}
native-vlan-id VLAN999;
}
}
}
ge-1/0/34 {
description "ASR2 0/0/5";
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members VLAN100;
}
native-vlan-id VLAN999;
}
}
}
description "ASR2 0/0/5";
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members VLAN100;
}
native-vlan-id VLAN999;
}
}
}
ge-0/0/30.0 up VLAN999 999 untagged unblocked
VLAN100 100 tagged unblocked
VLAN100 100 tagged unblocked
ge-1/0/34.0 up VLAN999 999 untagged unblocked
VLAN100 100 tagged unblocked
VLAN100 100 tagged unblocked
I also have an IP address for VLAN 100 configured on Juniper6
VLAN100 {
vlan-id 100;
l3-interface vlan.0;
}
vlan-id 100;
l3-interface vlan.0;
}
vlan {
unit 0 {
family inet {
address 10.10.100.3/24;
}
}
}
unit 0 {
family inet {
address 10.10.100.3/24;
}
}
}
Any help would be appreciated.